Author Topic: Internet Explorer 8 - problem with site  (Read 1671 times)

[SJ]Andrew Dawes

  • *
  • Posts: 221
Internet Explorer 8 - problem with site
« on: June 16, 2009, 01:23:57 pm »
I installed IE8 a couple of days ago because it was part of windows updates.  I've noticed that scroll on the text boxes is all screwed up.  Hard to describe but here goes: when you are typing and the scrollbar on the right is active because your text fills more than the viewable space vertically every second letter you type sends you to the top of the box (visually - not the acutal cursor) and then the next letter sends you back to the text which basically makes it impossible to type.  This happens on threads and PMs.

I've resovled this by using firefox on the site.

Not sure if its just simjunkies but it used to be fine so i put it down to IE8.  More plausible that MS screwed up rather than Marcus making a mistake with the site.

Oh and only a totally unrelated note - have the smilies sped up recently - i specifically refer to this guy  :excited: and this guy :yes: they seem to be on more caffeine than normal.

[SJ]Krister Larsson

  • *
  • Posts: 101
Re: Internet Explorer 8 - problem with site
« Reply #1 on: June 16, 2009, 01:30:18 pm »
Have the same problem when I test it with IE8. Don't hurt me though since I'm a Firefox fan and user :hats off:

[SJ]Byron

  • *
  • Posts: 7361
Re: Internet Explorer 8 - problem with site
« Reply #2 on: June 16, 2009, 01:58:00 pm »
We do have some issues with Internet Explorer - which is a bit of a bugger as it's still the most popular browser by a long way (mainly entirely due to MS's aggressive marketing) - but I'd strongly recommend switching to Firefox, Andrew.  It's free, it's open source, and it will solve ALL your browsing issues!  And Bill Gates doesn't get a penny!

As to the smileys - I made the newer ones at 24 fps, just so I could get some character into their movement - only to discover older versions of IE could only play GIFs at 12 fps, which is why you have been seeing them in slow motion!

 :)

[SJ]Andrew Dawes

  • *
  • Posts: 221
Re: Internet Explorer 8 - problem with site
« Reply #3 on: June 16, 2009, 01:59:27 pm »
Oh and only a totally unrelated note - have the smilies sped up recently - i specifically refer to this guy  :excited: and this guy :yes: they seem to be on more caffeine than normal.


Ha ha - i've just worked out the speed difference is between firefox and IE.

Edit: You beat me to it Byron.
« Last Edit: June 16, 2009, 02:02:50 pm by [SJ]Andrew Dawes »

[SJ]Kristof Huyck

  • *
  • Posts: 2686
Re: Internet Explorer 8 - problem with site
« Reply #4 on: June 16, 2009, 02:29:52 pm »
I've recently switched from firefox to google chrome and I like it so far  :) So that might be a good alternative to IE8 as well.

Marcus

  • *
  • Posts: 8167
Re: Internet Explorer 8 - problem with site
« Reply #5 on: June 16, 2009, 07:53:04 pm »
Really IE8 is garbage.  There is a forum I visit often, and they run their boards in an iframe.  Anytime I use IE8 on his site the window tries to minimize and follow my cursor around.  I actually have to leave my cursor on the bottom right of the page if I want to read his site in IE8.

lol

We will be trying to fix the errors we have in other browsers, but that will be after we've finished getting rid of operational bugs, and switching to the new forum software. 

 :P

[SJ]Riven

  • *
  • Posts: 812
Re: Internet Explorer 8 - problem with site
« Reply #6 on: June 17, 2009, 12:05:55 am »
Part of the issue with sites and IE8 is that they have "IE fixes" built into the CSS/JS becasue IE previously wasnt CSS standard.

Now with IE8 it is (supposedly) and when the IE "fix" is applied it breaks the IE8 rendering engine.

Simple fix for IE8 users is to enable "compatability mode" which puts IE8 back into IE7 mode for your current site only and it remembers it for that site on each visit.

Compatability Mode is the 'broken white page' symbol at the right hand end of the URL bar, next to the refresh and stop.

I enabled that for SJ, and havent had a single issue since :)

Marcus

  • *
  • Posts: 8167
Re: Internet Explorer 8 - problem with site
« Reply #7 on: June 18, 2009, 09:22:43 am »
Do you have discoloring around the 'frame' of the content?

[SJ]Andrew Dawes

  • *
  • Posts: 221
Re: Internet Explorer 8 - problem with site
« Reply #8 on: June 18, 2009, 11:03:38 am »
Do you have discoloring around the 'frame' of the content?


Don't know what that means.  I just tried to test and i couldn't replicate.

Marcus

  • *
  • Posts: 8167
Re: Internet Explorer 8 - problem with site
« Reply #9 on: June 18, 2009, 08:50:55 pm »
Let me post a pic.  :)  Do you see the two tone green around the logo and other areas?  Are the login fields at the top all wonky?  

This is what I see in IE8.  Still trying to figure out how to fix it.  

Compatibility mode makes it worse for me.  

The top image is IE

The bottom is FF

[SJ]Kristof Huyck

  • *
  • Posts: 2686
Re: Internet Explorer 8 - problem with site
« Reply #10 on: June 18, 2009, 09:01:33 pm »
Just viewed our website in IE8 and it's the same as Marcus' screenshot. Just did a comparison between FireFox, Chrome and IE and the first 2 showed the website correctly, I guess IE just sucks  :dunno:

[SJ]MrDee

  • *
  • Posts: 1170
Re: Internet Explorer 8 - problem with site
« Reply #11 on: June 18, 2009, 09:41:31 pm »

   I tried IE8 went it first came out in beta. It wasn't good and it seems it is still not. The only diff's I can see between the FF view and the view I get with IE7 is the font size in GMT clock is too big. :D

[SJ]Warren Dawes

  • *
  • Posts: 918
Re: Internet Explorer 8 - problem with site
« Reply #12 on: June 18, 2009, 11:50:40 pm »
I'm using IE8 but my home page looks ok, as per the FF screenshot from Marcus.  :dunno: