Author Topic: HELP, no online GTL  (Read 3378 times)

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
HELP, no online GTL
« on: January 17, 2009, 02:32:19 pm »
Hi,

Sorry to bother you but;

I can't get online in GTL.
Other sims like GTR2 and rFactor let me go to the lobby , np.
But in GTL when I click 'log-in' I get 'please wait..' and then;
'could not connect to the server'

I tried umpteen times , reboot, everything, no change.
I made a new GTL install, same problem!

I'm lost. With ESJ tonight and OSJ tomorrow morning I hope to find a clue as to what might be wrong.
If anyone has an idea, please tell me.

Thanks for reading.

Caspar.

[SJ]Byron

  • *
  • Posts: 7361
Re: HELP, no online GTL
« Reply #1 on: January 17, 2009, 02:33:58 pm »
Have you tried creating a new log in, Cas?

Just do a new name and password, and you'll need your online key number too.

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #2 on: January 17, 2009, 02:47:55 pm »
Will try that, thanks

result:
At which point the online key is asked for?
Staright after, with new name and password and  clicking register or log-in I get 'please wait' 'can't connect' etc.
« Last Edit: January 17, 2009, 02:55:19 pm by [SJ]CasparGTL »

[SJ]Grimwart

  • *
  • Posts: 752
Re: HELP, no online GTL
« Reply #3 on: January 17, 2009, 03:11:01 pm »
I just tried registering a new online name and connecting, didn't get asked for my key once through the whole process.

[SJ]Byron

  • *
  • Posts: 7361
Re: HELP, no online GTL
« Reply #4 on: January 17, 2009, 03:16:57 pm »
Maybe create a new User in GTL first, with a completely fresh PLR file, then go and create a new online account.

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #5 on: January 17, 2009, 03:31:18 pm »
I created a new user but never get asked for the online key.
It just says; 'registering failed, could not connect etc.'

[SJ]Byron

  • *
  • Posts: 7361
Re: HELP, no online GTL
« Reply #6 on: January 17, 2009, 03:40:40 pm »
Somewhere in the back of my mind I have a foggy memory of something similar happening to me.  I seem to recall it was an entry in the multiplayer part of the plr file somewhere.

Sorry I can't be more specific Cas.

I'm all out of ideas.

 :(

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #7 on: January 17, 2009, 03:54:06 pm »
No worries Byron.
It's guys like you that help me go at it.  thumbs up

I'll have a serious look in the PLR

If anyone could PM me their multiplayer part of the PLR so I could have a look?
If so, great.

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #8 on: January 17, 2009, 04:45:11 pm »
Problem seems to be somewhere else, not in PLR.
I compared settings from other SJ but it didn't do the trick.

I read at racesimcentral there was something similar
http://forum.racesimcentral.com/showthread.php?t=297263&highlight=can%27t+connect+online

They talk about the line;
Multiplayer Enum Type="1" // 0 = LAN, 1 = Internet
But changing back and forth to LAN or Internet didn't solve my problem.
(Jim Bartel and Dent have it at LAN and their GTLworks fine)

Our [SJ]fnugen solved it by using a host file (post7) or something.
I'll have to search further but if anyone knows what he's on about.
(I emailed him to ask  :))

[SJ]Jim

  • *
  • Posts: 89
Re: HELP, no online GTL
« Reply #9 on: January 17, 2009, 05:13:39 pm »
Cas,

You can look at your system host file - its located in windows/system32/drivers/etc/hosts

There shouldnt be anything in there referring to GTL. Here is a copy of mine.

# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
::1             localhost


Also, you can go to your cmd window (start/run/cmd) and type nslookup gtl-server.net

It should resolve to ip address 81.3.59.61 which is the gtl lobby. Check it out and see whatcha get.

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #10 on: January 17, 2009, 05:16:31 pm »
 :jawdrop: New hope! Thanks Jim!

Will report in a jiffy...I hope.  :)

[SJ]RockyC

  • N.A. League Manager
  • *
  • Posts: 3213
Re: HELP, no online GTL
« Reply #11 on: January 17, 2009, 05:23:43 pm »
Well, I can't help you now Cas, but I can tell you that the OSJ GTL race is not until next week. :)

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #12 on: January 17, 2009, 05:26:36 pm »
Haha, very nice Rocky, thanks. thumbs up

Well, here's what I have;

in windows/system32/drivers/etc/ I have a hosts file and a hosts.orig file
The host.orig file gives the text you said about Microsoft etc.
The hosts file gives an IP 127.0.0.1, followed by 'localhost www.gtl-server.net'
That doesn't look right then does it?

Before I screw up (yes I'll make backups) , which should I delete/rename etc?

Caspar.

PS

PS2

I'm IN!!!!!!!
deleting the hosts file with gtl stuff did the trick!

Thanks so much Jim and all who stuck with me!!!
Big kiss!
The run/cmd etc gave the info you mentioned.  :salute:
« Last Edit: January 17, 2009, 05:33:03 pm by [SJ]CasparGTL »

[SJ]Jim

  • *
  • Posts: 89
Re: HELP, no online GTL
« Reply #13 on: January 17, 2009, 05:31:14 pm »
is it 127.0.0.1 Localhost www.gtl-server.net?

[SJ]Pierre61

  • Master of Ceremonies
  • *
  • Posts: 7109
Re: HELP, no online GTL
« Reply #14 on: January 17, 2009, 05:31:44 pm »
I had the same problem (not asking for reg key) when trying to set Charlie up on my old machine ... I'm afraid I had to do a complete Windows reinstall before I could get it to ask for the key .... seems it's buried somewhere very deep, not even in the registry. I tried all other methods and Googled it for ages ... all I could come up with was a reinstall.
I hope you find something less drastic works for you Cas, but if all else fails, I think a reinstall will definitely cure it.

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #15 on: January 17, 2009, 05:33:53 pm »
I'm IN!!!!!!!
deleting the hosts file with gtl stuff did the trick!

Thanks so much Jim and all who stuck with me!!!
Big kiss!

[SJ]Pierre61

  • Master of Ceremonies
  • *
  • Posts: 7109
Re: HELP, no online GTL
« Reply #16 on: January 17, 2009, 05:35:44 pm »
Great news!  thumbs up

[SJ]Jim

  • *
  • Posts: 89
Re: HELP, no online GTL
« Reply #17 on: January 17, 2009, 05:41:12 pm »
Super, glad I could help!  thumbs up

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: HELP, no online GTL
« Reply #18 on: January 17, 2009, 05:43:31 pm »
 thumbs up smackeroo :excited: :dance:

[SJ]Stein

  • "The Watchdog"
  • *
  • Posts: 9033
Re: HELP, no online GTL
« Reply #19 on: January 17, 2009, 05:47:32 pm »
Here's some more info for the guys that are wondering what the hell is going on... glad you solved it in the meantime, SJ is a great place huh?


http://www.mvps.org/winhelp2002/hosts.htm


EDit.. here you can find your hostfile (in xp at least) C:\WINDOWS\system32\drivers\etc

[SJ]Byron

  • *
  • Posts: 7361
Re: HELP, no online GTL
« Reply #20 on: January 17, 2009, 06:09:46 pm »
Rock on Caspar!

 :funk:

[SJ]JuneBug

  • *
  • Posts: 2751
Re: HELP, no online GTL
« Reply #21 on: January 17, 2009, 08:46:31 pm »
EDit.. here you can find your hostfile (in xp at least) C:\WINDOWS\system32\drivers\etc


It resides in the same place under vista however to save modifications to the file in Vista one generally needs to run notepad.exe as an Administrator or saving the file can fail.

Just a tid bit of info is all, for in case purposes  :)