Author Topic: GTL @ G25 problem  (Read 2282 times)

[SJ]GizMoTo

  • League Director
  • *
  • Posts: 8010
GTL @ G25 problem
« on: July 23, 2009, 07:55:04 pm »
GTL won't recognise Revers, 5th and 6th on the G25 stick H setting

when setting the wheel buttons  it does nothing when you try and set those gears :?:
 1st to 4th  set fine along with all other settings

ther are no problems with GTR, GTR2, Race07 or any other game just GTL

any help would be usefull

TiA  Giz

[SJ]Pierre61

  • Master of Ceremonies
  • *
  • Posts: 7109
Re: GTL @ G25 problem
« Reply #1 on: July 23, 2009, 07:59:49 pm »
Could you try manually setting them in the plr using the same values as in your GTR2 plr?

this section...

Control - Reverse Gear="(0, 89)"
Control - First Gear="(0, 89)"
Control - Second Gear="(0, 89)"
Control - Third Gear="(0, 89)"
Control - Fourth Gear="(0, 89)"
Control - Fifth Gear="(0, 89)"
Control - Sixth Gear="(0, 89)"
Control - Seventh Gear="(0, 89)"

[SJ]GizMoTo

  • League Director
  • *
  • Posts: 8010
Re: GTL @ G25 problem
« Reply #2 on: July 23, 2009, 08:10:51 pm »
don't think that will work but I will try it tomorrow when I go visit

reason I say that is GTL isn't recognising the buttons.17, 18, and 19 I think they are going off the other profiles is very strange with all the other games working

TiA Pete if it works though  :hats off:

[SJ]Kristof Huyck

  • *
  • Posts: 2686
Re: GTL @ G25 problem
« Reply #3 on: July 23, 2009, 10:33:26 pm »
The only issue I know of is that you can't assign the 'top' buttons from the shifter module.

These are the setting in my plr regarding gears:

Control - Neutral="(0, 89)"
Control - Reverse Gear="(1, 27)"
Control - First Gear="(1, 21)"
Control - Second Gear="(1, 22)"
Control - Third Gear="(1, 23)"
Control - Fourth Gear="(1, 24)"
Control - Fifth Gear="(1, 25)"
Control - Sixth Gear="(1, 26)"

[SJ]GizMoTo

  • League Director
  • *
  • Posts: 8010
Re: GTL @ G25 problem
« Reply #4 on: July 24, 2009, 07:42:23 am »
OK I've manually added the buttons BUT the problem is  GTL isn't recognising the buttons  :hmm: :dunno: double checked it and all other games are and will select them so it's solely a GTL only thing ..............if worst comes to worst using it will just have to be used without H shifter :|

this is on a vista 64bit system :hmm:.    I think I'll try reinstalling the wheel drivers see if that fixes it :dunno: :dunno:

again thanks for the help any other suggestions most welcome :hats off:

[SJ]Stein

  • "The Watchdog"
  • *
  • Posts: 9033
Re: GTL @ G25 problem
« Reply #5 on: July 24, 2009, 02:40:37 pm »
Nearly at the bottom of my plr, i have these settings,  (yet i use 6th gear as reverse so i dont have to push the stick down..saves the unit maybe, plus it's definately faster)

Control - Shift Up="(1, 17)"
Control - Shift Down="(1, 18)"
Control - Neutral="(0, 89)"
Control - Reverse Gear="(1, 26)"
Control - First Gear="(1, 21)"
Control - Second Gear="(1, 22)"
Control - Third Gear="(1, 23)"
Control - Fourth Gear="(1, 24)"
Control - Fifth Gear="(1, 25)"

these are mine m8ey... i take it you have checked the wires? going to the wheel (bottom?)

Unplugging any joystick you might have in there so that your wheel is the only controller?


No other suggestions, hope you get it working m8ey



Woof ~ Woof & :salute:

[SJ]Jarkko Rantajoki

  • *
  • Posts: 12811
Re: GTL @ G25 problem
« Reply #6 on: July 24, 2009, 04:33:52 pm »
OK I've manually added the buttons BUT the problem is  GTL isn't recognising the buttons  :hmm: :dunno: double checked it and all other games are and will select them so it's solely a GTL only thing ..............if worst comes to worst using it will just have to be used without H shifter :|

this is on a vista 64bit system :hmm:.    I think I'll try reinstalling the wheel drivers see if that fixes it :dunno: :dunno:

again thanks for the help any other suggestions most welcome :hats off:


I have windows 7 64 bit and i have couple buttons it wont regognise, but they are the black ones on the top.. do you have any other controllers attached?
Maybe thats the problem.

[SJ]Pierre61

  • Master of Ceremonies
  • *
  • Posts: 7109
Re: GTL @ G25 problem
« Reply #7 on: July 24, 2009, 04:36:44 pm »
Do you have the profiler software (or any other software that uses dxinput) running? perhaps the button presses are being intercepted before they get to GTL?

[SJ]GizMoTo

  • League Director
  • *
  • Posts: 8010
Re: GTL @ G25 problem
« Reply #8 on: July 25, 2009, 02:10:56 am »
Do you have the profiler software (or any other software that uses dxinput) running? perhaps the button presses are being intercepted before they get to GTL?

 

:shy: the man gets a prize  :excited: sodding ideazone Z engine profiler was running thought that was off  8-O...........forgot that a GTL /driving games profile was being made  :(

 now got all but the top black buttons like Kristof mentioned  working  so good to go  :excited: :excited:

[SJ]Pierre61

  • Master of Ceremonies
  • *
  • Posts: 7109
Re: GTL @ G25 problem
« Reply #9 on: July 25, 2009, 02:15:45 am »
Whooha!