Author Topic: CTD when loading GTL quick race  (Read 3898 times)

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
CTD when loading GTL quick race
« on: June 02, 2007, 11:49:44 am »
Hi,

I just encountered a strange problem in GTL. :?:

Online racing is fine.
Offline practice is fine.

Offline quick race gives CTD. :(
I tried different cars (single make), different tracks, short races, long races, all sessions, just race, deleting HAT files but nothing gets me to the track.
The crash happens near the end of the track loading.

Has this happened to anyone else?
Never had this problem before.

Cheers, :)

Caspar

[SJ]GizMoTo

  • League Director
  • *
  • Posts: 8010
Re: CTD when loading GTL quick race
« Reply #1 on: June 02, 2007, 11:57:22 am »
any particular track  :?: :?:

[SJ]Jarkko Rantajoki

  • *
  • Posts: 12811
Re: CTD when loading GTL quick race
« Reply #2 on: June 02, 2007, 12:29:04 pm »
Sounds like a dodgy addon install to me. It can be a real bitch to locate.. just gotta go throught your folders..  :jawdrop:
(i might be wrong of course, but definitely sounds like that)

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: CTD when loading GTL quick race
« Reply #3 on: June 02, 2007, 12:48:19 pm »
I will go on a journey... :bye:

[SJ]DRokK

  • Sultan De Alfatina
  • *
  • Posts: 3922
Re: CTD when loading GTL quick race
« Reply #4 on: June 02, 2007, 12:50:08 pm »
sounds like the problem alan(madmax)  had, think it was caused by the GTR tracks,shared folder thingimebob.

[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: CTD when loading GTL quick race
« Reply #5 on: June 02, 2007, 06:39:06 pm »
Thanks, they go first! Temporalalililly :)

[SJ]Kristof Huyck

  • *
  • Posts: 2686
Re: CTD when loading GTL quick race
« Reply #6 on: June 04, 2007, 03:01:06 pm »
sounds like the problem alan(madmax)  had, think it was caused by the GTR tracks,shared folder thingimebob.



Well, you have to add the provided files to the shared folder and not replace the folder  :)

If the problem only occurs with GTR2 tracks --> probably forgotten to add those extra files in the shared folder
If you only can load GTR2 tracks --> you've probably replaced the original shared folder


[SJ]CasparGTL

  • rFactor Test Driver
  • *
  • Posts: 7790
Re: CTD when loading GTL quick race
« Reply #7 on: June 04, 2007, 03:05:19 pm »
Thanks for the reply.

The problem also occurs at Anderstorp and such, so not just GTR tracks, alas.

Caspar.

[SJ]SergeBMW

  • *
  • Posts: 72
Re: CTD when loading GTL quick race
« Reply #8 on: June 16, 2008, 11:21:55 pm »
I also have the same frustrating problems, I thought it would happen with the tracks here but it did, now I cant even race and I just joined this league, mabey a fresh reinstall would help?

[SJ]MaK

  • *
  • Posts: 353
Re: CTD when loading GTL quick race
« Reply #9 on: June 16, 2008, 11:49:31 pm »
sorry if you knew this already, but when gtr2 or gtl crashes you can try to run it in 'trace' mode.

to do so, simply add '-trace=100' (without the quote) in the shortcut you use to launch the game.

example for me : E:\games\gtl\GTL.EXE -trace=100

with that parameter, a file called trace.txt file will be created in your ..\GTL\UserData\LOG folder, and there will info about all the stuff the game is trying to do, so when it crashes you should see what causes the crash (hopefully)

might help or be totally useless, but for sure worth a try.

take care


[SJ]SergeBMW

  • *
  • Posts: 72
Re: CTD when loading GTL quick race
« Reply #10 on: June 17, 2008, 12:00:30 am »
OHH thankyou sooooo much, I did what you said and I found out that one of my addon cars wasnt initialising correctly and thats what messed it all up, so I deleted it an everything works great! thanks again :)

[SJ]Dion Holzheimer

  • Graduate of Alien U.
  • *
  • Posts: 1700
Re: CTD when loading GTL quick race
« Reply #11 on: June 17, 2008, 12:33:16 am »
I'll have to do this to find out why 90% of my replays cause a CTD... remember this trace... hmm..

[SJ]GT_Raycer

  • *
  • Posts: 1145
Re: CTD when loading GTL quick race
« Reply #12 on: June 18, 2008, 10:25:13 am »
I think I had a problem like that once when I tried to load up a Quick Race using only a single make of car... :think:

If I remember it right, I just had to use a CLASS of cars.   :dunno:

[SJ]OldGreazy

  • *
  • Posts: 1065
Re: CTD when loading GTL quick race
« Reply #13 on: June 18, 2008, 12:09:05 pm »
Whenever I've had this problem in the past it has been due to a bad install of some addon cars. I would get a CTD just as any track was completing it's load process.

Good Luck Caspar thumbs up

[SJ]HPI-rcr

  • *
  • Posts: 860
Re: CTD when loading GTL quick race
« Reply #14 on: June 28, 2008, 02:22:53 pm »
alright, now I am having a problem......

I was running with loads of fellas last night, on SJ server, running fine on default tracks, in default cars, then came Monza Jr..

CTD, CTD, CTD, CTD....

Loaded up a race offline, same car, same track........... all was fine.

Loaded up to go back to server, CTD.

Reinstalled the track, loaded up off line, 25 ai, just fine.

Put up a host, same car same track.......... CTD.

Tried to join server, CTD.

Loaded up off line, ran fine......

HELPP!!!!!!!!!!!

I get this with Hockenheim too, I think.

Also, when I try to add the GTL.EXE -trace=100 thinggy...... It changes the file extension so I can't run it.... Am I just getting stupid in my old age....???
Used to be able to do all this stuff.

« Last Edit: June 28, 2008, 02:38:37 pm by [SJ]HPI-rcr »

[SJ]MaK

  • *
  • Posts: 353
Re: CTD when loading GTL quick race
« Reply #15 on: June 28, 2008, 03:59:50 pm »
Also, when I try to add the GTL.EXE -trace=100 thinggy...... It changes the file extension so I can't run it....


just to be sure you did it correctly

'right click' on the shortcut you use to launch the game and select 'properties', then change the stuff according to the image below.

if this doesn't work for you, you can also create a .bat file that will launch the game with the specific parameters. Let us know if you have problems doing that.

hope it helps, running it in trace mode is a good first step to find out what may cause the crash.

[SJ]MaK

  • *
  • Posts: 353
Re: CTD when loading GTL quick race
« Reply #16 on: June 28, 2008, 04:08:24 pm »
also just thought about this, if your gt legends is installed in a folder that has some space character in it, be sure you add the quotes at the correct position.

"E:\games\GT Legends\GTL.exe" -trace=100

[SJ]HPI-rcr

  • *
  • Posts: 860
Re: CTD when loading GTL quick race
« Reply #17 on: June 28, 2008, 04:42:04 pm »
thx MaK....

Working on it know, trying to duplicate it....

Will let you know.